8-800-200-555-4
+7 (34767) 7 07 03

Доработка с помощью расширений печатных форм

Доработка с помощью расширений печатных форм

Для доработки надо в модуле менеджера документа захватить две процедуры

  • ДобавитьКомандыПечати()
  • Печать()
&После("ДобавитьКомандыПечати")
Процедура ЗаказНаПроизводство_ДобавитьКомандыПечати(КомандыПечати)
	
	Команда = КомандыПечати.Добавить();
	Команда.Представление = НСтр("ru = 'Заказ на производство (расширение)'");
	Команда.Идентификатор = "ЗаказНаПроизводство";
	Команда.Порядок = 500;

КонецПроцедуры
&Перед("Печать")
Процедура ЗаказНаПроизводство_Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода)
	
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ЗаказНаПроизводство");
	Если ПечатнаяФорма <> Неопределено Тогда
		ПечатнаяФорма.ТабличныйДокумент = ПечатьЗаказаНаПроизводство(МассивОбъектов, ОбъектыПечати, "ЗаказНаПроизводство");
		ПечатнаяФорма.СинонимМакета = НСтр("ru = 'Заказ на производство'");
		ПечатнаяФорма.ПолныйПутьКМакету = "Документы.СчетНаОплату.ПФ_MXL_СчетЗаказ";
	КонецЕсли;

КонецПроцедуры
Для получения печатной формы используем обработку ПечатьЗаказаНаПроизводство(), где происходит заполнения табличного документа
Внедренный продукт:

Заказать внедрение
Форма заказа

Возврат к списку